home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / bluez-utils-2.22-r1 / bluez-utils-2.22-r1.ebuild < prev    next >
Text File  |  2006-05-15  |  3KB  |  115 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/bluez-utils-2.22-r1.ebuild,v 1.4 2006/01/23 14:12:04 wolf31o2 Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="Bluetooth Tools and System Daemons for using Bluetooth under Linux"
  8. HOMEPAGE="http://bluez.sourceforge.net/"
  9. SRC_URI="http://bluez.sourceforge.net/download/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~hppa ppc sparc x86"
  14.  
  15. IUSE="alsa cups dbus gtk pcmcia"
  16.  
  17. RDEPEND="!net-wireless/bluez-pan
  18.         >=net-wireless/bluez-libs-2.22
  19.         dev-libs/libusb
  20.         alsa? ( >=media-libs/alsa-lib-1.0.9 )
  21.         cups? ( net-print/cups )
  22.         dbus? ( >=sys-apps/dbus-0.31 )
  23.         gtk? ( >=dev-python/pygtk-2.2 )
  24.         pcmcia? ( virtual/pcmcia
  25.                   sys-apps/setserial )"
  26. DEPEND="sys-devel/bison
  27.         sys-devel/flex
  28.         >=sys-apps/sed-4
  29.         ${RDEPEND}"
  30.  
  31. src_unpack() {
  32.     unpack ${A}
  33.     cd ${S}
  34.  
  35.     if has_version '>=sys-apps/dbus-0.60' ; then
  36.         epatch ${FILESDIR}/${PN}-2.22-dbus-0.60.patch
  37.     fi
  38.  
  39.     sed -i \
  40.         -e "s:^HIDD_ENABLE=.*:HIDD_ENABLE=false:" \
  41.         -e "s:^HID2HCI_ENABLE=.*:HID2HCI_ENABLE=false:" \
  42.         ${S}/scripts/bluetooth.default
  43.  
  44.     sed -i \
  45.         -e "s:security .*;:security user;:" \
  46.         ${S}/hcid/hcid.conf
  47.  
  48.     if use gtk; then
  49.         sed -i -e "s:\(pin_helper \).*:\1/usr/bin/bluepin;:" \
  50.             ${S}/hcid/hcid.conf
  51.     else
  52.         sed -i -e "s:\(pin_helper \).*:\1/etc/bluetooth/pin-helper;:" \
  53.             ${S}/hcid/hcid.conf
  54.     fi
  55. }
  56.  
  57. src_compile() {
  58.     econf \
  59.         $(use_enable alsa) \
  60.         $(use_enable cups) \
  61.         $(use_enable dbus) \
  62.         $(use_enable pcmcia) \
  63.         $(use_enable gtk bluepin) \
  64.         --enable-avctrl \
  65.         --enable-bcm203x \
  66.         --enable-dfutool \
  67.         --enable-hid2hci \
  68.         --enable-obex \
  69.         --disable-initscripts \
  70.         --localstatedir=/var \
  71.         || die "econf failed"
  72.  
  73.     emake || die "emake failed"
  74. }
  75.  
  76. src_install() {
  77.     make DESTDIR="${D}" install || die "make install failed"
  78.  
  79.     dodoc AUTHORS ChangeLog README
  80.  
  81.     # optional bluetooth utils
  82.     cd ${S}/tools
  83.     dosbin bccmd hcisecfilter ppporc pskey
  84.  
  85.     exeinto /etc/bluetooth
  86.     newexe ${FILESDIR}/${P}-pin-helper.sh pin-helper
  87.  
  88.     insinto /etc/bluetooth
  89.     newins ${FILESDIR}/${P}-pin pin
  90.     fperms 0600 /etc/bluetooth/pin
  91.  
  92.     newinitd ${FILESDIR}/${P}-init.d bluetooth
  93.     newconfd ${S}/scripts/bluetooth.default bluetooth
  94.  
  95.     # bug #103498
  96.     if use pcmcia; then
  97.         fperms 755 /etc/pcmcia/bluetooth
  98.     fi
  99. }
  100.  
  101. pkg_postinst() {
  102.     einfo
  103.     einfo "A startup script has been installed in /etc/init.d/bluetooth."
  104.     einfo
  105.     einfo "If you need to set a default PIN, edit /etc/bluetooth/pin, and change"
  106.     einfo "/etc/bluetooth/hcid.conf option 'pin_helper' to /etc/bluetooth/pin-helper."
  107.     einfo
  108.  
  109.     if use gtk; then
  110.         einfo "By default, /usr/bin/bluepin will be launched on the desktop display"
  111.         einfo "for pin number input."
  112.         einfo
  113.     fi
  114. }
  115.